Oct 20 2009

A new windows Automated Installer v2.4+ has been released for get_iplayer. Most notably it installs a version of flvstreamer that uses cygwin libraries rather than the version compiled using mingw32. This reportedly helps resolve the notorious ‘10060’ flvstreamer error that many users were getting. The non-cygwin flvstreamer is still available as an install-time option.

9 Comments

  • On October 21st, 2009, Emilio said:

    Thanks a lot!
    Report me as one of the users getting that error.
    Hope this new realese works for me now.
    I’ll come back to tell. 🙂

    • On October 21st, 2009, Emilio said:

      It worked!! Thanks a lot for this new realese. It solved the 10060 error perfectly fine. 🙂

      • On October 23rd, 2009, Steve said:

        Thanks, this works great.

        First downloaded get_iplayer at the start of the year. Worked great until one this error message rendered the script useless. But all working great now. Can download lovelly HD H.264 without watching it over yucky flash! 🙂

        • On November 4th, 2009, Pete said:

          Hi – totally new to get_iplayer – used the latest file above to install and managed to record BBC – used the –type=itv as per the documentation to try to get a programme from the itv player but get an error that itv is not valid – what am I doing wrong?

          • On November 4th, 2009, linuxcentre said:

            Sorry – I’ve removed the references to ITV in the documantition now since it is no longer supported.

          • On November 7th, 2009, Duplicity said:

            I love get_iplayer but it peaked with being able to get all the channels, now to be left with BBC only it’s sadly losing its charm.
            what has happened? are you being sued/threatened

            • On November 8th, 2009, linuxcentre said:

              No. ITV radically changed their site and I guess someone will have to rewrite the plugin. Ch4 just kept permanently blacklisting IPs to make life difficult for users so rather than annoy users I dropped it. I suggest getting a TV/PVR 🙂

            • On November 13th, 2009, Sam said:

              Could you please add proxy support to your NSIS installer? I think there are plugins that make it possible.

              It’s not clear where to put the ffmpeg/flvstreamer files etc. if I download them manually when the installer fails to. (Also I had to look through proxy logs to find out exactly which locations to download from). Also the installer silently failed to download the perl script too.

              Alternatively, could you make a zipped version of the software available with everything in it and ready to go?

              • On November 13th, 2009, linuxcentre said:

                A few days ago there was an extended website outage here when our hosting provider decided to take a long time to fix their systems – that would have caused the installer to fail. I’ve migrated the hosting elsewhere during the outage so hopefully we’ll not have the same problem for a while…

                The NSIS script is distributed with the installer. If you manage to get it working please let me know and I’ll release a new one.

              WordPress Themes