[phpBB Debug] PHP Notice: in file /viewtopic.php on line 981: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead
[phpBB Debug] PHP Notice: in file /viewtopic.php on line 981: getdate(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead
Linuxcentre • View topic - [solved] :'s in Filename/Subdirectories

[solved] :'s in Filename/Subdirectories

Discussions regarding the development of get_iplayer

[solved] :'s in Filename/Subdirectories

Postby thomas.willson » 21 Jan 2010 02:50

Is there any chance you could add an option to replace :'s with -'s because in OS X they are illegal characters in a filename and show up as \'s in Finder?

The forum is an excellent idea by the way.
thomas.willson
 
Posts: 4
Joined: 21 Jan 2010 02:48

Re: :'s in Filename/Subdirectories

Postby linuxcentre » 21 Jan 2010 08:14

I'd rather not add yet another option for this because it's not an illegal character. Have you tried the -fatfilenames option to see if that helps?
linuxcentre
Site Admin
 
Posts: 306
Joined: 31 Dec 2009 17:29

Re: :'s in Filename/Subdirectories

Postby NetworkNed » 21 Jan 2010 10:52

Hi Thomas,

Is the forum software mangling the characters of your post? Both apostropies appear the same here, and if I create a new file or folder by copying & pasting your text it appears fine:
Code: Select all
$ touch Desktop/"replace 's with -'s"
$ ls -l !!:$
ls -l Desktop/"replace 's with -'s"
-rw-r--r--  1 ned  staff  0 21 Jan 10:51 Desktop/replace 's with -'s
$

It appears fine in both Finder and Terminal.
The forum's avatar functionality is currently disabled. :(
NetworkNed
 
Posts: 22
Joined: 21 Jan 2010 02:04

Re: :'s in Filename/Subdirectories

Postby thomas.willson » 21 Jan 2010 14:42

The thing to be replaced was supposed to be a colon which is what OS X uses to delineate paths.
thomas.willson
 
Posts: 4
Joined: 21 Jan 2010 02:48

Re: :'s in Filename/Subdirectories

Postby NetworkNed » 21 Jan 2010 14:52

thomas.willson wrote:The thing to be replaced was supposed to be a colon which is what OS X uses to delineate paths.

Ah, ok. I can reproduce that. On my Linux system I have no filenames with colons in them, though.

Is --file-prefix not useful?
The forum's avatar functionality is currently disabled. :(
NetworkNed
 
Posts: 22
Joined: 21 Jan 2010 02:04

Re: :'s in Filename/Subdirectories

Postby linuxcentre » 21 Jan 2010 16:23

thomas.willson wrote:The thing to be replaced was supposed to be a colon which is what OS X uses to delineate paths.

That is strange. Is it just an OS X app which is mis-diplaying it? Bacuse I thought OS X was Unix and : chars are definitely allowed... You just need to escape them in a shell. e.g. in bourne shell:
Code: Select all
echo hello > my\:file.txt
cat my\:file.txt
linuxcentre
Site Admin
 
Posts: 306
Joined: 31 Dec 2009 17:29

Re: :'s in Filename/Subdirectories

Postby NetworkNed » 21 Jan 2010 20:27

Ok... I don't know anything about this problem myself... Mr Wilson's explanation that "a colon ... is what OS X uses to delineate paths" doesn't really make sense to me.

But, anyway, Finder is the Mac equivalent of Window's Explorer, explorer.exe. I'm not quite sure of the KDE / Gnome equivalent, or even if they have one. Finder is the GUI program you use for exploring the file system, looking in your home directory or Documents for that elusive PDF you saved there - if you double-click on that PDF in Finder it'll open in a PDF viewer, just as you'd expect. But Finder is also responsible for putting the icons on the desktop, just as explorer.exe is on XP.

So, yes, it IS a Mac app which is misdisplaying the colon, but a core Mac app, not one you can just swap out or throw away.

I used the code example in the last post and made a screen shot showing the problem - look on the right-hand side of the desktop.

I'm guessing this is because Jobs wanted users to be able to make folders called "Junk / Miscellaneous" and stuff like that, but I have no idea whether this traces back to OS 9 or NextStep. I just tried making a folder on the Desktop and I could use an "&" sign and an exclamation mark, too. If I make a new folder in Finder and name it "foo / bar" it shows as a "foo : bar" when I `ls` the directory, just as I guess you'd expect from the screenshot.

HTH,

Ned.
The forum's avatar functionality is currently disabled. :(
NetworkNed
 
Posts: 22
Joined: 21 Jan 2010 02:04

Re: :'s in Filename/Subdirectories

Postby linuxcentre » 22 Jan 2010 01:25

Hi Thomas, did the --fatfilenames option work?
linuxcentre
Site Admin
 
Posts: 306
Joined: 31 Dec 2009 17:29

Re: :'s in Filename/Subdirectories

Postby thomas.willson » 24 Jan 2010 04:43

Well, I thought I posted a reply. Anyway, that fatfilenames option didn't fix the problem.
thomas.willson
 
Posts: 4
Joined: 21 Jan 2010 02:48

Re: :'s in Filename/Subdirectories

Postby linuxcentre » 24 Jan 2010 11:21

thomas.willson wrote:Well, I thought I posted a reply. Anyway, that fatfilenames option didn't fix the problem.

So there must be an additionaly problem as this option removes ':' characters. Can you enlighten me?
linuxcentre
Site Admin
 
Posts: 306
Joined: 31 Dec 2009 17:29

Next

Return to development



Who is online

Users browsing this forum: No registered users and 1 guest

cron
./cache/ is NOT writable.